(AS3) expressInstall.png not loading on correct path

So i’m using the AS3 icer.ink mediaserver and the expressInstall.png file is being loaded on http://media1.clubpenguin.com/play/upgrade/images/expressInstall.png
and media1 is down obviously.

It’s being loaded from sites/default/files/js/js_jpJjaUC0z8JMIyav5oQrYykDRUb64rpaUDpB4Y9aklU.js

and i can’t edit it to the right path. Tried to edit index.html but no success. environment data is correct. Running on localhost. Here’s the image

Don’t forget, there are two sets of environmental_data.xml. Only one of them is used, either media1/play/web_service/environment_data.xml or play/web_service/environment_data.xml. Find out which one it uses, then edit it to load from the correct path.

I don’t understand what you are trying to do though, are you trying to load the expressInstall.png image so that you can enable flash or just to load it there for the websites design. If you’re trying to enable flash, you don’t need the expressInstall.png image loaded, it’s not necessary. All you have to do is enable flash in your browser.

Google Chrome: https://helpx.adobe.com/flash-player/kb/enabling-flash-player-chrome.html

Mozilla Firefox: https://helpx.adobe.com/flash-player/kb/enabling-flash-player-firefox.html

Microsoft Edge: https://helpx.adobe.com/flash-player/kb/flash-player-issues-windows-10-edge.html

Internet Explorer: https://helpx.adobe.com/flash-player/kb/install-flash-player-windows.html

Safari: https://helpx.adobe.com/flash-player/kb/enabling-flash-player-safari.html

I also doubt that it’s being loaded from sites/default/files/js/js_jpJjaUC0z8JMIyav5oQrYykDRUb64rpaUDpB4Y9aklU.js as that file has no occurrences of media1.clubpenguin.com. It’s being loaded either from environmental_data.xml (one that you haven’t configured) or another SWF file perhaps? I’ve never really noticed the image when setting it up.

https://icer.ink/play.clubpenguin.com/sites/default/files/js/js_jpJjaUC0z8JMIyav5oQrYykDRUb64rpaUDpB4Y9aklU.js

Alright, fixed everything but now after logging in the game there’s no servers. Already tried to fix it before you call me “lazy”

You gotta make sure the IDs specified in the local_crumbs matches w the ones in the global_crumbs, that’s the only thing that could cause it AFAIK so double check both crumbs, make sure you uploaded both ones.

Not working. Tried to change from Houdini AS3 to Timeline but it’s still not working.

Tried to change from Houdini AS3 to Timeline

That’s server-sided, my instructions were client-sided (local and global crumbs).

At least from changing source, you’ve realized it’s all client sided (all to do with the media server) as it’s had no effect. As I said earlier, the only thing that could cause this is your local and global crumbs AFAIK.

Double check them, the server IDs should match the correct servers etc.

Already checked them. it’s correct but it’s not working.

Could you provide screenshots or attachments of both files?

global_crumbs.swf (771 Bytes)

local_crumbs.swf (3.1 KB)

And yes, i’m running the server on the correct ID

Your local crumbs is different to the default one, consider using the default one?

Here: local_crumbs.swf (2.7 KB)

I changed “Blizzard” to “SB01 Environment” as i’m making sandbox servers.

Still not working even after using default.

Very odd.

But i mean even using default one’s at the beginning and changing the name of the server works. And switching from “Houdini” to “Timeline” won’t do anything if you are trying to do the same thing you did in “Houdini”.

But i am guessing you changed something in local crumbs that was not just the server name.

Thanks.

As i said 300 million times, everything is correct and default.

Then perhaps it’s caching your older versions of the file, remember to clear your browser cache before trying.

What media server are you using? It’s not a problem with any of the default files, many people are able to setup Houdini or Timeline with the clients we provide, the only reason an issue occurs is due to anything you modified or added or misconfigured.

Consider anything you have edited or added.