Help with "You have found" Instead of "Buy" item?

Hi there! Really new with this sort of stuff. Recently put together an AS2 CPPS with Kitsune, just as a little side project as I’m very interested in learning more about Club Penguin/CPPS’ in general, and hooked it up with Hamachi just so my friend could play on it and test it out with me. Not looking to make it public, but I noticed that when I try to buy an item from any catalogue (tried changing catalogues multiple times), it says “You have found (x)” instead of “Would you like to buy (x)”, and when I click “Yes”, after it asks if I would like to “pick up” this item without enough coins, I’m greeted with an infinite loading screen. I assume the problem is because it says “You have found” rather than “Would you like to buy?”, prompting an empty response. If anyone could tell me how to fix this, or give me any advice on fixing this it would be greatly appreciated. Thanks!

And to add, when I do purchase an item from the catalogue with above the amount of coins required to buy the item, it still says “You have found (X), would you like to pick it up?”, and does indeed take the coins off of me when I click “Yes”, but I’m not greeted with the “(X) has been added to your inventory” confirmation box either.

Pretty sure it only says You have found when the item is free

Yeah that’s what I thought, but it does take the coins off of me when I have above the required amount, but still says “You have found (x)”, in every catalogue apart from the igloo items.

What media server are you using?

Bare with me, very new to this sort of stuff haha.
Here’s the media server I’m using, it hasn’t got a visible name!tHgXDL7b!7ntOEETeipnTA3k0P340djyH1e_XL7wLJHs_IvHjSH4

It’s from this video, didn’t use the tutorial, just needed a media server quickly.

I thought it might be something to do with Kitsune’s “Item.php” handler maybe? I’m not sure though. If it’s the media server, would you have any recommendations of good media servers that work well with Kitsune? :slight_smile:

Houdini’s legacy media server is a pretty good one -

It’s also very easy to setup, all you got to do is unzip it, set up the sub-domains for it and then configure the play page (/play/index.html) and configure your IPs and ports in the javascript bit in the head section of the html page. That is all.

I would recommend using Houdini over Kitsune, it is an emulator written in python2.7 and has complete handlers for the AS2 client. I can’t recall if Kitsune AS2 had any missing handlers, but regardless I don’t think it should cause your prompt issue. I suspect that the issue is client related, specifically with the interface or the catalogues.

I would say try using the legacy media server first, if it still doesn’t work then try using Houdini. Whatever works for you :slight_smile: